Available modules

Below is a list of the available modules, installed on our CPU nodes. To use this module, please refer to the documentation.
If you need additional modules, we manage the installation of modules using Spack. If you find the required software with the spack packages list, we should be able to provide on the DCE. In that case, let us know at dce_support(arobase)groupes.renater.fr .

compilers

  • gcc/12.3.0
  • gcc/13.1.0
  • intel-oneapi-compilers/2023.1.0

languages

  • anaconda3/2022.10
  • apptainer/1.1.7
  • apptainer/1.1.9
  • lua/5.4.4
  • py-graphviz/0.13.2

libraries

  • cuda/11.1.1
  • cuda/11.3.1
  • cuda/11.4.4
  • cuda/11.7.1
  • cuda/12.1.1
  • hdf5/1.10.7
  • hdf5/1.12.3
  • intel-oneapi-mkl/2023.1.0
  • intel-oneapi-mpi/2021.9.0
  • mongodb/6.2
  • netcdf-c/4.9.2
  • netcdf-fortran/4.6.0
  • openblas/0.3.23
  • openblas/0.3.26
  • opencv/4.6.0
  • openmpi/4.1.5
  • py-cartopy/0.21.1
  • py-h5py/3.8.0
  • py-matplotlib/3.7.1
  • py-mesa/2.2.4
  • py-mpi4py/3.1.4
  • py-netcdf4/1.6.2
  • py-numpy/1.24.3
  • py-pandas/2.0.1
  • py-scikit-learn/1.2.2
  • py-scipy/1.11.2
  • py-websockify/0.11.0
  • py-xarray/2022.3.0
  • qt-svg/6.6.1

other

  • intel-mkl/2020.4.304
  • py-jupyter/1.0.0
  • py-jupyterlab-server/2.10.3
  • udunits/2.2.28

softwares

  • abinit/9.10.3
  • abinit/9.10.5
  • code-server/4.11.0
  • freeglut/3.2.2
  • gnuplot/5.4.3
  • gnuplot/6.0.0
  • grace/5.1.25
  • graphviz/8.0.1
  • py-jupyter-core/5.3.0
  • py-notebook/6.4.12
  • sem3d/2024.02.22
  • turbovnc/3.1.1

tools

  • agate/1.4.1
  • cmake/3.26.3
  • ffmpeg/6.0
  • lmod/8.7.24
  • mongo-tools/4.2
  • nmap/7.93
  • qagate/1.3.0
  • subversion/1.14.2
  • valgrind/3.20.0